
Skinning Guide using Paint Shop Pro 

To use this guide, you must have the following software: 

• Paint Shop Pro, 7.04 or similar 
• Winzip 

This guide will lead you through modifying a player skin for medal of honor: allied assault. 

PART ONE 

First, an overview.  The skins are made by modifying the existing skins and files.  There are three parts to the player skins: 

Textures - the actual graphics.  
Shaders - the file that tells MOH where to find the graphics 
TIKI files - The file that tells MOH which model to use, and which shader to use. 

To make a player skin you need: 

.tik file (player model, assigns gear) 

.tik fps file (player's first-person view) 
shader 
head texture 
hand (fps) texture 
hand texture 
upper body texture 
lower body texture 
helmet texture (if required) 
gear texture (if required) 

1. First, go to your moh:aa main, or if in spearhead (SH), mainta folders.  Use winzip to open pak0.pk3 or pak1.pk3 (SH)  

There you will find most of the important files.  Click "TYPE" at the top of the winzip window, to sort your files into file types.  Scroll down 
until you find all files with the type, "TIK". These are most of the items in the game.  Weapons, furniture, vehicles etc. Its not the complete 
model, but the TIKI for the model (see above).   We're interested in the player skins.  For this example, we'll use the 6th Airborne 
Captain, the guy with the red beret. 

2. Locate the files allied_british_6th_Airborne_Captain.tik and allied_british_6th_Airborne_Captain_fps.tik  
3. Click the file allied_british_6th_Airborne_Captain.tik and hold CTRL, click allied_british_6th_Airborne_Captain_fps.tik so that 

both are selected.   
4. Click the EXTRACT button.   
5. Confirm that "Use Folder Names" is selected  
6. Choose a location for your files.  

This is vital.  You must maintain the correct file structure for your files.  When we've edited them, they need to return to the same place 
we got them from. Just placing them anywhere will cause problems.  For this, I use a zip disk, my I: drive.  You can use a floppy disk if 
you like, or your root C: folder.  Do not place them in a sub-folder somewhere.  Use the root folder.  

7. Once you've chosen your location, hit EXTRACT again.  

Now, scroll through the list of files until you find the SHADER files.  For Spearhead, its easy. 

8. Find the file called "mohta_Characters.shader" and extract it to your drive.  

Most of the new Spearhead skins are in the same shader file, which is handy.  For the original game, its a bit more challenging.  Most of 
the shaders are the same name as the model, so have a browse and see what you can find. You'll pretty much be writing your own 
shader anyway.  

Now, to find the textures. In MOH, you'll need to be in pak2.pk3.  In SH, just remain in pak1.pk3 for now.  

9. At the top of your winzip window, click PATH to change the sorting by file location, not type.  Scroll down to find:  

textures/models/player  



In there you'll find the textures for the player models, and you'll see the paratrooper for our demo.  This is interesting... You'll 
see that the file types are .jpg files.  In the original game, all player textures were of a type, .tga. We'll see more about that 
later.  Ignore the .dds files for now, just extract the .jpg files as you did with the tiks and shader.   

10. Extract  uk_air_pt_coat.jpg, uk_air_pt_pants.jpg, uk_air_pt_gear.jpg  

Look around for the textures/models/human/faces location and-  

11. Extract the uk_pt_capt.jpg   

Have a look for- 

12. pt_hands.jpg and extract that too.  

Ok, thats about all we need for the moment.    

13. Close Winzip.  

PART TWO 

Use Windows Explorer (or whatever) to go to the drive you selected to hold your extracted files.  You'll see three folders: 

o Models : contains your .tik files in a sub-folder called "Player", so, models/player  
o Scripts : holds your .shader  
o Textures : holds your images.  

Open the one called Textures first.  You'll see some sub-folders. 

textures/models/human  

Go into the faces folder, and you'll see the texture for the captain.  Open it in Paint Shop Pro. Go back and open all of the 
files.  The hands, the body, the gear.  We will look at them all at once.  

Use the magnifying tool to resize your images so that you can see them all together.   

Now, there are a lot of ways you can go with this... It all depends on your skill with Paint Shop Pro.  If you have never used it 
before, I suggest you stop now, and go search for all of the general tutorials you can find.  Here's a few links: 

http://www.pspug.org/tut/tut7eff.shtml 

http://www.jasc.com 

Once you're familiar with the tools, we can begin. 

PART THREE 

First we'll get rid of those patches on the arms.   

1. To do most of the work you'll be using the clone tool. .  On the tool options, select a size of about 16, opacity (density of 
the paint) of 100.  Very carefully right click on a blank area, (see pic) and then brush over the edge of the pouch  

 

http://web.archive.org/web/20061209144853/http:/www.pspug.org/tut/tut7eff.shtml
http://web.archive.org/web/20061209144853/http:/www.jasc.com/


    

original mid-way complete bad example 

All I can say about cloning is TAKE your time.  The example on the right is what you'll get if you go to fast.  Click, move a bit, 
click, move a bit.  

*** 

Layers.  Yes. Layers.  These are the entire key to making skins, or pretty much anything look decent.  To stop us from totally 
buggering up our original skin, we're going to duplicate it.  

• Click on Layers, Duplicate.    

If you look at your Layers toolbar, you'll see you now have two layers, the same. If you don't have a layers palette, click View 
> Toolbars and click the Layer Palette option. 

Before we stick a patch on, we're going to colour the uniform.  There's a million ways you can do this. Lets try a few.   

*** 

• EDIT > Copy.  
• EDIT > Paste.  

This just gives us another texture, so we don't stuff the original. 

 

• On the colour selection menu, click Foreground Colour and the solid paint option.  
• Click on the current colour (Black, in the screenshot) and you'll open the colour pallete.  
• Choose a green.  I picked #92C884 as mine, but use what you like.  For the moment, we're 

just practicing.   

  



 

•  Go to and from the options toolbar, choose "Colour to Target", Size 
46, Opacity about 50.  

Brush onto your image, and you'll see you're changing the uniform green, but not 
totally wrecking the textures. 

• Hammer UNDO until you've removed the colour, and go select 
another colour, say a grey, or a brown.  

Use something thats a "uniform". Try two colours at once. This is just messing 
around, but you get the point. 

• Again, hammer UNDO until you're back to the original colours.    

  

*** 

Another way to do this is to use a coloured layer. 

• Click LAYERS > NEW RASTER LAYER.  

You'll see that on your Layer Pallette, you'll have a new, transparent layer. 

• Choose a colour, and choose the Fill tool.    

Don't worry too much about settings, just click on your image and you'll get a big slab of our colour, over the entire uniform. 
Go to your Layer Pallete and on the right hand side, click the arrow next to normal.  You'll see a few options, Screen, Multiply, 
etc.  Click them all to try them.  You'll see that you have some working well, others... don't.  

• Choose "Colour" and then drag the slider (100%) to the left, and you'll see the layer start to get less intense.  Once 
you've seen the effect, put it back to 100%.   

So... Your uniform is coloured.  But, the undershirt is also coloured.  So are the straps.  Say you don't want that to 
happen.  Well, again there's a few ways to fix this. 

 

• From the toolbar, select the freehand selection tool. 

Choose the options Point to Point, Feather 0, and 
turn on antialias.  

• Select, by clicking, moving, clicking, moving around the 
neck area on the shirt.  

• Press Delete, and the original texture colour will show 
through.  

Basically you delete that section of the green filled layer, letting the 
original show through.  You can also do the same for the equipment 
straps if you wanted to. Here's an incomplete example. 

Anyway, thats about it.   

***  



There's a pretty funky file that might help you with camo, but it is a plug-in to PSP.  Here is the link... http://www.v-d-
l.com/adrenaline_camouflage.html 

Download it, follow the instructions to set up, and go back into PSP. 

Info on setting up Plug-Ins can be found here. 

*** 

o Undo everything so you have  your original uniform texture.  
o Add a Layer > Duplicate Layer.  
o Go to Effects, Plug-Ins, VDL Adrenaline, Camouflage.    

This opens up the camo options - you'll see there are a LOT of settings you can mess around with.  

• Choose something you like and click Ok.  

Again, you'll get a large slab of camo.  Play with your Layers Palette as you did above.  The best seems to be "soft light" but 
"dodge" usually works ok too.  It depends on the effect you're looking for. 

*** 

So there you have it.  Thats most of the texturing you'll need.  Lets get serious and do it for real. 

o Open the texture you're using.  
o Clone out anything you don't want.  
o Colourise with the colour to target tool. (mine is mid-grey)  

 
(50% of actual size) 

• Duplicate the Layer   
• Add some Camo (Mine is Common - Red, Scale 33, Blur 50, Fall off 15, Random 1)  
• Adjust Layer to depth (Mine is 54% Multiply)  
• Clean up Camo (removed camo from straps and under shirt)  

http://web.archive.org/web/20061209144853/http:/www.v-d-l.com/adrenaline_camouflage.html
http://web.archive.org/web/20061209144853/http:/www.v-d-l.com/adrenaline_camouflage.html
http://web.archive.org/web/20061209144853/http:/www.psphelp.com/pref.html


 

...and thats about it.  Just have to add the patch on the sleeve now. 

***  

Now, lets add a new patch.  I've chosen a patch from the allied airborne.  I just did a search on Google for "military patch".   

Here's the original. 

o Right click, copy it, and paste it into PSP.   

 

• Use the magic want tool , and click in the white areas (not the writing).  
• Go to Selection > Inverse to select just the patch.   
• Edit > Copy it again, and click on your uniform.  
• Edit > Paste as New Layer.  Your patch is now on your uniform.   
• Image > Resize... You'll have to guess here, but I'm doing Pixel Size, 125.  

Make sure you don't have "ALL Layers".  Its ok, but looks a little "hard".   

• Select the magic wand again, and change the "feather" to 2.  
• Click on the image NEAR the patch and it'll select it.  
• Press Delete twice, and your patch will have a slightly fuzzy edge.  
• SELECTIONS > Select None.  
• Now drop the layer's density a bit on the Layer Pallete, from 100% to whatever looks good.  

The patch is probably upside down, so- 

• IMAGE > Flip, then IMAGE > Mirror.  
• Reposition it by dragging it with the moving tool.  

http://web.archive.org/web/20061209144853/http:/www.google.com/


Put it on the other sleeve, if you want. To save the completed picture- 

• click on SAVE AS, not SAVE.  
• Change the file type to a tga file.  
• Name it demo_coat.tga  
•  Save it to your drive, in textures.  Don't worry about any other subfolders.   

The completed image looks like this: 

 
demo_coat.tga 

(the example here is a tad blurry... sorry)  

***  

Continue the texturing by yourself for the remaining textures.  Seriously though, its not worth the effort messing around with 
hands, or faces just yet, unless you're REALLY good with the paint tools.  Use the face off another model, and one of the 
standard hand sets.  Here's what I have, after altering the other textures. 



 
face - just a 
russian guy 

 
pants at 50% actual 

 
hands at 50% actual 

 
Gear at 50% actual  

  

demo_face.tga demo_pants.tga demo_hands.tga demo_gear.tga 

Save all the finished files in your textures folder, as .tga files.  
*** 

PART FOUR. 

Open your mohta_Characters.shader SHADER file in Notepad. 

It looks complicated, but look at the individual parts; 

usa_pt_top The name of the shader section. Must be 
unique. 

{ 
 qer_editorimage textures/models/human/usa_paratrooper/air_pt_coat.tga Where to get the textures... 

{ 
 map textures/models/human/usa_paratrooper/air_pt_coat.tga ...same. 

rgbGen lightingSpherical Type of lighting 
} 

 } 
 

Basically, for each part of your skin, you need a part for in the shader. 

So... Lets do our demo guy. In a new notepad document, type:  

 

demo_coat 
{ 
qer_editorimage textures/demo_coat.tga 
{ 
map textures/demo_coat.tga 
rgbGen lightingSpherical 
} 
} 

demo_pants 
{ 
qer_editorimage textures/demo_pants.tga 
{ 
map textures/demo_pants.tga 
rgbGen lightingSpherical 
} 
} 



demo_face 
{ 
qer_editorimage textures/demo_face.tga 
{ 
map textures/demo_face.tga 
rgbGen lightingSpherical 
} 
} 

demo_hands 
{ 
qer_editorimage textures/demo_hands.tga 
{ 
map textures/demo_hands.tga 
rgbGen lightingSpherical 
} 
} 

demo_gear 
{ 
qer_editorimage textures/demo_gear.tga 
{ 
map textures/demo_gear.tga 
rgbGen lightingSpherical 
} 
} 

 

There's other ways to do it, but I find this is the easiest.  The only thing you need to watch is that your shader names 
(demo_face etc) are different from any other skin.  So don't go calling it "airborne_coat" or something, or you'll get conflicts.  I 
probably should call mine wolf-man_demo_coat or something.  

Once completed and checked- 

o click FILE > SAVE AS and go to your 'scripts' folder.  
o Name the file something suitable, I'm using demo_guy.shader  
o Close the shader file.  

...if you're doing a president clinton skin, you'd call it something like, president_clinton.shader.  You get the point. 

*** 

Now for the .tik files... this is the hardest bit.  

o Open up, in notepad, the allied_british_6th_Airborne_Captain.tik file we extracted earlier.   

It looks like this:  My comments are in blue. 

 

TIKI 
setup 
{ 
scale 0.52  This is the size of the file.  Most things are this size.  If you made it smaller, you'd have a 
little guy running around. So leave it. 
path models/human/allied_airborne This is the model's (skeleton, without texture) location. 
skelmodel airborne.skd This is the model.  Manon, for example, has a different one. 
 
surface shirt shader uk_pt_top This is pointing to the shader file we did a minute ago.  
surface pants shader uk_pt_pants 
surface sleeve shader uk_pt_top_cull 
 
path models/human/heads 
skelmodel head1.skd This is the model's head shape.  There's a few different ones.  Play with the 
numbers, head1, head3 etc. 
surface head shader uk_head_pt_capt  This is the shader for the head. 
 
// HANDS 
// ======================================================= 



path models/human/hands 
skelmodel hand.skd 
surface hand shader pt_hands ...shader for the hands. 
 
// GEAR 
// ======================================================= 
path models/equipment/USGear/airborne 
skelmodel airborne_gear.skd 
surface gear shader airborne_gear This is the gear's shader...  
 
// HELMET 
// ======================================================= 
path models/human/brit-beret 
skelmodel brit-beret.skd 
surface brit_beret shader brit_beret The headgear.  In our case, we aren't having a headgear... YET. 
} 
 
init 
{ 
server 
{ 
voicetype british // set the voicetype to use for multiplayer instant messaging  Voice type... SAS, Axis4 
are examples.  Study the games .tik files to find more. 
} 
} 
 
$include models/player/base/include.txt 

 

So now to make our own.  Don't retype it, thats dumb.  Change these bits:  

surface shirt shader uk_pt_top  to surface shirt shader demo_coat 
surface pants shader uk_pt_pants to surface pants shader demo_pants 
surface sleeve shader uk_pt_top_cull to surface sleeve shader demo_coat 
   skelmodel head1.skd  to skelmodel head4.skd  (or whatever) 
surface head shader uk_head_pt_capt to surface head shader demo_face 
   surface hand shader pt_hands to surface hand shader demo_hands 
surface gear shader airborne_gear to surface gear shader demo_gear 
   path models/human/brit-beret 
skelmodel brit-beret.skd 
surface brit_beret shader brit_beret  

to //path models/human/brit-beret 
//skelmodel brit-beret.skd 
//surface brit_beret shader 
brit_beret   

(this removes the beret, temporarily. 
We might use it later.) 

voicetype british // set the voicetype to use for 
multiplayer instant messaging  voicetype axis4 // set the voicetype 

to use for multiplayer instant 
messaging 

Once you've checked it, go to: 

o FILE > SAVE AS and put it in models/player  
o Name it german_demo_guy.tik  

The 'german' part in the name is for team selection.  Other choices are allied, russian or british.  This also signifies weapon 
choice in Multiplayer. 

***  

The next part is the FPS TIKI.   

Open, in notepad, the file allied_british_6th_Airborne_Captain_fps.tik from where you extracted it earlier.   

Again, comments are in blue. It looks like this: 

 



TIKI 
setup 
{ 
path models/player/US_Army 
skelmodel USarmyplyr.skd Every skin is the same...  
 
surface viewsleeves shader viewsleeves_dak This is the sleeve you see when you're holding a gun.   
surface triggerhand shader handview The hand...  
surface lefthand shader handview ...same 
surface garandhand shader handview ...same.  
} 
 
$define pulloutdir sound/weapons/pullout 
 
$include models/player/base/include_fps.txt 

 

Basically, the only thing you need to change is the sleeve view to the right colour.  Our guy is in a grey-black camo, so it'd 
probably take a custom sleeve.  I'm not going to bother now, maybe in a later tutorial.  Just leave it how it is for the time being. 

o SAVE AS > german_demo_guy_fps.tik in your models/player folder.  

*** 

We're about done.  All we have left is to compile the files and add them to the pk3. 

o Go into your models/player folder.  
o Right click on the file, german_demoguy.tik and choose winzip > add to german_demoguy.zip  

This will create a zip icon. 

• Open it, and you'll see one of your file added.  

But there's a problem.  The file has not maintained its folder pathway, and won't work. 

• Delete the file german_demoguy.tik, we need to add it again with folder names.   
• Organise your windows so that you can see the opened zip file, and the .tik files.  
• Drag the german_demoguy.tik into the zip window. It will ask you some options. 

You MUST make sure the option "Save Full Path Info" is selected. 

• Then hit ADD.  

You'll see the file is added, WITH folder names.  

• Repeat this process of dragging files into the zip file. Remember to make sure the folder paths are added.  

You need the two tik files, the shader, and all your textures. 

The final zipped file should be: 



 

• Close the zip file, and go to where it is saved.  Probably models/player.  
• Right click it and rename it "user-skin-demo_guy.pk3"  
• Now click EDIT > CUT  
• Move to your MOH:AA mainta folder.  
• EDIT > Paste and your pk3 will appear.  

Now its ready, and in the game.  Start Spearhead and go to your MP options.  The skin should appear in the german 
selection of models. 

...and here he is. 



 

End... for now. 

 


